No Wallis stock currently available in UK
Incident Report for Prezzee
Resolved
We regret to inform you that Wallis has been discontinued and is no longer available for sale in the UK.

We sincerely apologize for any inconvenience this may cause.
Posted Sep 12, 2024 - 15:18 AEST
Update
We are continuing to work on a fix for this issue.
Posted Jun 20, 2023 - 20:04 AEST
Identified
We’re experiencing a stock issue with Wallis UK. We’re working hard to get more stock ASAP.
Please check back soon.

ref: MAR-305
Posted Jun 20, 2023 - 20:04 AEST