Superette NZ $50 now back in stock
Incident Report for Prezzee
Resolved
We have successfully restocked Superette NZ $50 and these cards are now available for purchase.
Posted Sep 11, 2024 - 11:31 AEST
Identified
We’re experiencing a stock issue with Superette NZ $50. We’re working hard to get more stock ASAP.
Please check back soon.

ref: MAR-1120
Posted Sep 09, 2024 - 13:42 AEST
This incident affected: Stock Availability (NZ).