Gift Card Market US - Discontinued

Incident Report for Prezzee

Resolved

This is to notify you that Gift Card Market has been discontinued and is no longer available for sale in US.
MAR-2150
Posted Jun 16, 2026 - 01:46 AEST

Identified

We are experiencing a stock issue with Gift Card Market $100. We are working hard to get more stock ASAP.

Please check back soon.
MAR-2150
Posted May 11, 2026 - 01:14 AEST
This incident affected: Stock Availability (US).