We're back online with Currys IE £10.00 in UK
Incident Report for Prezzee
Resolved
We have resolved our technical issues and these cards are now available for purchase.

ref: MAR-1125
Posted Sep 16, 2024 - 10:09 AEST
Investigating
We’re having some technical issues at the moment with Currys IE eGift cards and working to fix this. Please check back soon!

ref: MAR-1125
Posted Sep 13, 2024 - 11:38 AEST
This incident affected: Stock Availability (UK).