TFE Hotels, AU $100 now back in stock

Incident Report for Prezzee

Resolved

We have successfully restocked TFE Hotels, AU $100 and these cards are now available for purchase.
Posted Oct 22, 2025 - 09:47 AEDT

Identified

We are experiencing a stock issue with TFE Hotels $100. We are working hard to get more stock ASAP.

Please check back soon.
MAR-1748
Posted Oct 14, 2025 - 15:51 AEDT
This incident affected: Stock Availability (AU).