We're back online with the UK eGift cards

Incident Report for Prezzee

Resolved

We have resolved our technical issues and the cards are now available for purchase.
Posted Feb 18, 2026 - 04:57 AEDT

Update

We’re experiencing some technical issues with the following eGift cards:

* Just Eat
* Google Play

We're working to fix this.
Please check back soon!

MAR-1981
Posted Feb 18, 2026 - 04:56 AEDT

Update

We’re experiencing some technical issues with the following eGift cards:

* Just Eat
* Xbox Currency
* Google Play

We're working to fix this.
Please check back soon!

MAR-1981
Posted Feb 18, 2026 - 02:46 AEDT

Investigating

We are experiencing some technical issues with the following eGift cards:

* Just Eat
* Xbox Currency

We are working to fix this.
Please check back soon!

MAR-1981
Posted Feb 18, 2026 - 02:17 AEDT
This incident affected: Stock Availability (UK).