Smoothie King, US $15, $20, $25, $50, $75, and $100 now back in stock

Incident Report for Prezzee

Resolved

We have successfully restocked Smoothie King, US $15, $20, $25, $50, $75, and $100 and these cards are now available for purchase.
Posted Dec 06, 2025 - 07:21 AEDT

Identified

We are experiencing a stock issue with Smoothie King $15, $20, $25, $50, $75, and $100. We are working hard to get more stock ASAP.

Please check back soon.
MAR-1817
Posted Nov 14, 2025 - 09:41 AEDT
This incident affected: Stock Availability (US).