We are experiencing technical issues with Petro-Canada $250 in CA

Incident Report for Prezzee

Update

We are currently having some technical issues with Petro-Canada $250 eGift cards.

Please check back soon.

MAR-1871
Posted Dec 04, 2025 - 23:07 AEDT

Update

We are currently having some technical issues with Petro-Canada $25, $50, $100 eGift cards.

Please check back soon.

MAR-1871
Posted Dec 04, 2025 - 14:48 AEDT

Update

We are currently having some technical issues with Petro-Canada $50, $100 eGift cards.

Please check back soon.

MAR-1871
Posted Dec 04, 2025 - 13:44 AEDT

Identified

We are currently having some technical issues with Petro-Canada $100 eGift cards in CA. Updates will be posted here once we know more. We apologise for any inconvenience this may cause.

Please check back soon.

MAR-1871
Posted Dec 04, 2025 - 12:54 AEDT
This incident affects: Stock Availability (CA).