Sephora, AU $100 now back in stock

Incident Report for Prezzee

Resolved

We have successfully restocked Sephora, AU $100 and these cards are now available for purchase.
Posted Jun 27, 2025 - 15:18 AEST

Identified

We are experiencing a stock issue with Sephora $100. We are working hard to get more stock ASAP.

Please check back soon.
MAR-1587
Posted Jun 25, 2025 - 17:38 AEST
This incident affected: Stock Availability (AU).