We're back online with the US eGift cards

Incident Report for Prezzee

Resolved

We have resolved our technical issues and the cards are now available for purchase.
Posted Apr 12, 2026 - 01:39 AEST

Investigating

We are experiencing some technical issues with the following eGift cards:

* Walmart
* Starbucks
* Sheetz
* Google Play
* Lyft
* Bath & Body Works
* Grubhub
* Sam’s Club
* Uber Eats

We are working to fix this.
Please check back soon!

MAR-2061
Posted Apr 11, 2026 - 21:18 AEST
This incident affected: Stock Availability (US).