We're back online with the NZ eGift cards

Incident Report for Prezzee

Resolved

We have resolved our technical issues and the cards are now available for purchase.
Posted Dec 04, 2025 - 18:34 AEDT

Investigating

We are experiencing some technical issues with the following eGift cards:

* Farmers
* SHEIN
* Neon
* Sephora


We are working to fix this.
Please check back soon!

MAR-1874
Posted Dec 04, 2025 - 17:53 AEDT
This incident affected: Stock Availability (NZ).