UK eGift cards are back online

Incident Report for Prezzee

Resolved

We have resolved our technical issues and the cards are now available for purchase.
Posted Oct 20, 2025 - 23:13 AEDT

Update

We’re experiencing some {intermittent} technical issues with the following eGift cards:


We're working to fix this.
Please check back soon!
Posted Oct 20, 2025 - 23:12 AEDT

Investigating

We’re experiencing some {intermittent} technical issues with the following eGift cards:


We're working to fix this.
Please check back soon!
Posted Oct 20, 2025 - 19:39 AEDT
This incident affected: Stock Availability (UK).