Best Restaurants, NZ $500 now back in stock

Incident Report for Prezzee

Resolved

We have successfully restocked Best Restaurants, NZ $500 and these cards are now available for purchase.
Posted Aug 11, 2026 - 17:56 AEST

Identified

We are experiencing a stock issue with Best Restaurants $500. We are working hard to get more stock ASAP.

Please check back soon.
MAR-2356
Posted Aug 11, 2026 - 14:40 AEST
This incident affected: Stock Availability (NZ).