We're back online with the UK eGift cards

Incident Report for Prezzee

Resolved

We have resolved our technical issues and the cards are now available for purchase.
Posted Dec 09, 2025 - 09:35 AEDT

Update

We’re experiencing some technical issues with the following eGift cards:

* Frasers
* Game
* Frasers Group
* Greggs

We're working to fix this.
Please check back soon!

MAR-1880
Posted Dec 08, 2025 - 19:44 AEDT

Investigating

We’re experiencing some technical issues with the following eGift cards:

* Frasers
* Game

We're working to fix this.
Please check back soon!

MAR-1880
Posted Dec 08, 2025 - 19:19 AEDT

Identified

We are currently having some technical issues with Frasers eGift cards in UK. Updates will be posted here once we know more. We apologise for any inconvenience this may cause.

Please check back soon.

MAR-1880
Posted Dec 08, 2025 - 17:53 AEDT
This incident affected: Stock Availability (UK).