Playstation Store CA $30 has been discontinued

Incident Report for Prezzee

Resolved

This is to notify you that Playstation Store $30 has been discontinued and is no longer available for sale in CA.

MAR-1683
Posted Sep 05, 2025 - 12:16 AEST

Identified

We are currently having some technical issues with Playstation Store $30 eGift cards in CA. Updates will be posted here once we know more. We apologise for any inconvenience this may cause.

Please check back soon.

MAR-1683
Posted Sep 05, 2025 - 10:54 AEST
This incident affected: Stock Availability (CA).