We're back online with the US eGift cards

Incident Report for Prezzee

Resolved

We have resolved our technical issues and the cards are now available for purchase.
Posted May 20, 2026 - 09:24 AEST

Update

We’re experiencing some technical issues with the following eGift cards:

* Wawa
* Hibbett Sports
* Texaco
* PacSun
* Miller's Ale House
* Advance Auto Parts
* Tire Discounters



We're working to fix this.
Please check back soon!

MAR-2172
Posted May 20, 2026 - 08:00 AEST

Update

We’re experiencing some technical issues with the following eGift cards:

* Wawa
* Hibbett Sports
* Texaco
* PacSun
* Miller's Ale House
* Advance Auto Parts



We're working to fix this.
Please check back soon!

MAR-2172
Posted May 20, 2026 - 07:08 AEST

Investigating

We are experiencing some technical issues with the following eGift cards:

* Wawa
* Hibbett Sports
* Texaco
* PacSun
* Miller's Ale House



We are working to fix this.
Please check back soon!

MAR-2172
Posted May 20, 2026 - 07:02 AEST
This incident affected: Stock Availability (US).