We're experiencing technical issues with some AU eGift cards

Incident Report for Prezzee

Update

We’re experiencing some technical issues with the following eGift cards:

* BP
* Spotify
* Norton 360 Premium
* Amaysim Prepaid
* Vodafone Pre-Paid
* Microsoft 365 Personal
* Microsoft 365 Business Standard
* Microsoft 365 Family
* Telstra Pre-Paid
* zGold MOL Points
* Starfield
* Lyca Mobile PrePaid
* Minecraft MineCoins
* Minecraft Legends
* Minecraft Win10 Starter Collection
* Boost Mobile Pre Paid
* Adobe CreativeCloud PhotographyPlan 21
* Razer Gold
* Xbox One Forza Horizon 5 VIP Membership - AU
* Xbox One Cuphead
* Xbox Forza Motorsport
* Xbox One NBA 2K 23 Points
* Xbox Starfield
* Xbox One NBA 2K24

We're working to fix this.
Please check back soon!

MAR-1505
Posted May 06, 2025 - 21:38 AEST

Update

We’re experiencing some technical issues with the following eGift cards:

* Norton 360 Premium
* BP
* Amaysim Prepaid
* Vodafone Pre-Paid
* Xbox One Forza Horizon 5 VIP Membership - AU
* Minecraft Legends
* Microsoft 365 Business Standard
* Telstra Pre-Paid
* zGold MOL Points
* Starfield
* Xbox One Cuphead
* Lyca Mobile PrePaid
* Microsoft 365 Personal
* Xbox Forza Motorsport
* Minecraft MineCoins
* Xbox One NBA 2K 23 Points
* Minecraft Win10 Starter Collection
* Xbox Starfield
* Boost Mobile Pre Paid
* Adobe CreativeCloud PhotographyPlan 21
* Razer Gold
* Xbox One NBA 2K24
* Microsoft 365 Family

We're working to fix this.
Please check back soon!

MAR-1505
Posted Apr 29, 2025 - 18:37 AEST

Investigating

We are experiencing some technical issues with the following eGift cards:

* Norton 360 Premium
* BP
* Amaysim Prepaid
* Vodafone Pre-Paid
* Xbox One Forza Horizon 5 VIP Membership - AU
* Minecraft Legends
* Microsoft 365 Business Standard
* Telstra Pre-Paid
* zGold MOL Points
* Starfield
* Xbox One Cuphead
* Lyca Mobile PrePaid
* Microsoft 365 Personal
* Xbox Forza Motorsport
Minecraft MineCoins
* Xbox One NBA 2K 23 Points
* Minecraft Win10 Starter Collection
* Xbox Starfield
* Boost Mobile Pre Paid
* Adobe CreativeCloud PhotographyPlan 21
* Razer Gold
* Xbox One NBA 2K24
* Microsoft 365 Family

We are working to fix this.
Please check back soon!

MAR-1505
Posted Apr 29, 2025 - 18:36 AEST
This incident affects: Stock Availability (AU).