We're back online with the US eGift cards

Incident Report for Prezzee

Resolved

We have resolved our technical issues and the cards are now available for purchase.
Posted May 29, 2026 - 04:33 AEST

Investigating

We are experiencing some intermittent technical issues with the following eGift cards:

Walmart
Sam's Club
DoorDash
Burlington
Macy’s
TJX Multi-Brand
Starbucks
Uber
Lyft
Marshalls
Lowe's
The Home Depot®
Carnival Cruise Lines
Pilot Flying J
eBay
Instacart
Academy Sports + Outdoors
Subway
T.J.Maxx
Airbnb
Chipotle
LongHorn Steakhouse
Olive Garden
Uber Eats
Ulta Beauty
Xbox Live
Applebee's®
Bath & Body Works
Chili's Grill & Bar
DICK’S Sporting Goods
Foot Locker
Apple
Best Buy
Chewy
Google Play
Jiffy Lube
CVS Pharmacy
Grubhub
HomeGoods
Hulu
Kohl's
Sheetz
BURGER KING
Barnes & Noble
PetSmart
Xbox
Albertsons
Darden Restaurants
Jersey Mike’s Subs
McAlister’s Deli
Nintendo eShop
Nordstrom
Visa® Reward Virtual Account, 12-Month Expiration $5 - $50
Buffalo Wild Wings
Delta Air Lines
Domino’s
[http://Hotels.com|http://Hotels.com|smart-link]

IHOP®
Papa John's
SONIC
Ace Hardware
Chuck E. Cheese’s
Cracker Barrel Old Country Store
Dutch Bros Coffee
Etsy
Guitar Center
Krispy Kreme Doughnut
Michaels
Princess Cruises
REI
Razer Gold
TopGolf
Total Wine
Walgreens
Amc Theatres
Ann Taylor
Build-A-Bear Workshop
Champs Sports
H&M
Logan’s Roadhouse
Nordstrom Rack
Outback Steakhouse
Panda Express
Peet’s Coffee & Tea
PlayStation Store
Regal
Royal Caribbean
Ruby Tuesday
Southwest
The Container Store
Visa® Reward Virtual Account, 12-Month Expiration $105 - $10000
Yard House

We are working to fix this.
Please check back soon!

MAR-2217
Posted May 29, 2026 - 03:29 AEST
This incident affected: Stock Availability (US).