No Cowshed stock currently available in UK
Incident Report for Prezzee
Resolved
We regret to inform you that Cowshed has been discontinued and is no longer available for sale in the UK.

We sincerely apologize for any inconvenience this may cause.
Posted Sep 12, 2024 - 14:51 AEST
Update
We’re still experiencing a stock issue with Cowshed UK. We’re working hard to get more stock ASAP.
Please check back soon.

ref: MAR-385
Posted Aug 22, 2023 - 20:56 AEST
Identified
We’re experiencing a stock issue with Cowshed UK £15.00, £20.00, £30.00, £40.00. We’re working hard to get more stock ASAP.
Please check back soon.

ref: MAR-385
Posted Aug 14, 2023 - 21:51 AEST