AmpolCash FUEL ONLY AU now back in stock

Incident Report for Prezzee

Resolved

We have successfully restocked AmpolCash FUEL ONLY AU and these cards are now available for purchase.
Posted Oct 23, 2025 - 01:06 AEDT

Identified

We are experiencing a stock issue with AmpolCash FUEL ONLY. We are working hard to get more stock ASAP.

Please check back soon.
MAR-1758
Posted Oct 21, 2025 - 18:32 AEDT
This incident affected: Stock Availability (AU).