We're back online with IKEA in UK
Incident Report for Prezzee
Resolved
We have successfully restocked IKEA UK and these cards are now available for purchase.
Posted Sep 03, 2024 - 02:45 AEST
Identified
We’re experiencing a stock issue with IKEA UK, 20, 150, 75, 10, 25 . We’re working hard to get more stock ASAP.
Please check back soon.

ref: MAR-1107
Posted Sep 01, 2024 - 03:51 AEST