Be Fit Food AU $150 & $200 now back in stock
Incident Report for Prezzee
Resolved
We have successfully restocked Be Fit Food AU $150 & $200 and these cards are now available for purchase.
Posted Sep 17, 2024 - 11:47 AEST
Identified
We’re experiencing a stock issue with Be Fit Food AU $150 & $200. We’re working hard to get more stock ASAP.
Please check back soon.

ref: MAR-1128
Posted Sep 15, 2024 - 10:58 AEST
This incident affected: Stock Availability (AU).