We have resolved our technical issues with Petro-Canada in CA. The cards are now available for purchase.
Posted Apr 20, 2026 - 12:32 AEST
Update
We are currently having some technical issues with Petro-Canada eGift cards in CA. Updates will be posted here once we know more. We apologise for any inconvenience this may cause.
Please check back soon.
MAR-2082
Posted Apr 20, 2026 - 09:32 AEST
Update
We are currently having some technical issues with Petro-Canada $25, $50, and $100 eGift cards.
Please check back soon.
MAR-2082
Posted Apr 19, 2026 - 23:50 AEST
Update
We are currently having some technical issues with Petro-Canada $50, and $100 eGift cards.
Please check back soon.
MAR-2082
Posted Apr 19, 2026 - 22:30 AEST
Identified
We are currently having some technical issues with Petro-Canada $50 eGift cards in CA. Updates will be posted here once we know more. We apologise for any inconvenience this may cause.