We are experiencing technical issues with Shari’s Berries in US

Incident Report for Prezzee

Update

We are currently having some technical issues with Shari’s Berries eGift cards in US. Updates will be posted here once we know more. We apologise for any inconvenience this may cause.

Please check back soon.

MAR-1580
Posted Jun 15, 2025 - 05:10 AEST

Identified

We are currently having some technical issues with Shari’s Berries $50 and $100 eGift cards in US. Updates will be posted here once we know more. We apologise for any inconvenience this may cause.

Please check back soon.

MAR-1580
Posted Jun 14, 2025 - 00:59 AEST
This incident affects: Stock Availability (US).