No David Jones $100 stock currently available in AU
Incident Report for Prezzee
Resolved
We have successfully restocked David Jones AU $100 and these cards are now available for purchase.
Posted Sep 06, 2024 - 13:51 AEST
Identified
We’re experiencing a stock issue with David Jones AU $100. We’re working hard to get more stock ASAP.
Please check back soon.

ref: MAR-919
Posted May 21, 2024 - 11:33 AEST