We're experiencing technical issues with some UK eGift cards

Incident Report for Prezzee

Update

We’re experiencing some technical issues with the following eGift cards:

* Sainsbury’s, Argos, TU & Habitat Multi Brand
* Sainsbury's
* Argos

We're working to fix this.
Please check back soon!

MAR-2337
Posted Jul 29, 2026 - 05:17 AEST

Investigating

We are experiencing some technical issues with the following eGift cards:

* Sainsbury’s, Argos, TU & Habitat Multi Brand
* Sainsbury's

We are working to fix this.
Please check back soon!

MAR-2337
Posted Jul 29, 2026 - 04:01 AEST
This incident affects: Stock Availability (UK).