We are experiencing technical issues with Strandbags $50, $100, and $250 in NZ

Incident Report for Prezzee

Update

We are currently having some technical issues with Strandbags $50, $100, and $250 eGift cards.

Please check back soon.

MAR-2440
Posted Sep 20, 2026 - 11:31 AEST

Update

We are currently having some technical issues with Strandbags $50, and $100 eGift cards.

Please check back soon.

MAR-2440
Posted Sep 20, 2026 - 10:06 AEST

Identified

We are currently having some technical issues with Strandbags $50 eGift cards in NZ. Updates will be posted here once we know more. We apologise for any inconvenience this may cause.

Please check back soon.

MAR-2440
Posted Sep 19, 2026 - 12:08 AEST
This incident affects: Stock Availability (AU).