We're back online with the US eGift cards

Incident Report for Prezzee

Resolved

We have resolved our technical issues and the cards are now available for purchase.
Posted Sep 11, 2025 - 11:30 AEST

Investigating

We are experiencing some technical issues with the following eGift cards:

* DoorDash
* Uber Eats
* Uber
* Airbnb



We are working to fix this.
Please check back soon!

MAR-1696
Posted Sep 11, 2025 - 10:59 AEST
This incident affected: Stock Availability (US).