We are experiencing technical issues with Nintendo eShop $35, and $99 in CA

Incident Report for Prezzee

Update

We are currently having some technical issues with Nintendo eShop $35, and $99 eGift cards.

Please check back soon.

MAR-2122
Posted May 05, 2026 - 07:00 AEST

Identified

We are currently having some technical issues with Nintendo eShop $99 eGift cards in CA. Updates will be posted here once we know more. We apologise for any inconvenience this may cause.

Please check back soon.

MAR-2122
Posted May 05, 2026 - 05:59 AEST
This incident affects: Stock Availability (CA).