We are back online with Morrisons in UK

Incident Report for Prezzee

Resolved

We have resolved our technical issues with Morrisons in UK. The cards are now available for purchase.
Posted Jul 19, 2026 - 08:49 AEST

Identified

We are currently having some technical issues with Morrisons eGift cards in UK. Updates will be posted here once we know more. We apologise for any inconvenience this may cause.

Please check back soon.

MAR-2310
Posted Jul 18, 2026 - 22:57 AEST
This incident affected: Stock Availability (UK).