We're back online with Swarovski £50 in UK
Incident Report for Prezzee
Resolved
We have successfully restocked Swarovski UK £50 and these cards are now available for purchase.
Posted Sep 17, 2024 - 22:21 AEST
Identified
We’re experiencing a stock issue with Swarovski UK £50. We’re working hard to get more stock ASAP.
Please check back soon.

ref: MAR-1124
Posted Sep 12, 2024 - 20:16 AEST
This incident affected: Stock Availability (UK).