RuneScape US - Discontinued

Incident Report for Prezzee

Resolved

This is to notify you that RuneScape has been discontinued and is no longer available for sale in US.
MAR-1762
Posted Oct 31, 2025 - 02:24 AEDT

Identified

We are experiencing a stock issue with RuneScape. We are working hard to get more stock ASAP.

Please check back soon.
MAR-1762
Posted Oct 22, 2025 - 11:50 AEDT
This incident affected: Stock Availability (US).