No Hey You $10 stock currently available in AU
Incident Report for Prezzee
Resolved
We have successfully restocked Hey You AU $10 and these cards are now available for purchase.
Posted Sep 05, 2024 - 15:01 AEST
Identified
We’re experiencing a stock issue with Hey You AU $10. We’re working hard to get more stock ASAP.
Please check back soon.

ref: MAR-826
Posted Mar 27, 2024 - 12:56 AEDT