We are experiencing technical issues with B&M £40, £60, £70, and £80 in UK

Incident Report for Prezzee

Update

We are currently having some technical issues with B&M £40, £60, £70, and £80 eGift cards.

Please check back soon.

MAR-2218
Posted May 30, 2026 - 01:34 AEST

Update

We are currently having some technical issues with B&M eGift cards in UK. Updates will be posted here once we know more. We apologise for any inconvenience this may cause.

Please check back soon.

MAR-2218
Posted May 29, 2026 - 22:29 AEST

Update

We are currently having some technical issues with B&M £50, and £60 eGift cards.

Please check back soon.

MAR-2218
Posted May 29, 2026 - 22:14 AEST

Identified

We are currently having some technical issues with B&M £50 eGift cards in UK. Updates will be posted here once we know more. We apologise for any inconvenience this may cause.

Please check back soon.

MAR-2218
Posted May 29, 2026 - 22:12 AEST
This incident affects: Stock Availability (UK).