We're back online with the US eGift cards

Incident Report for Prezzee

Resolved

We have resolved our technical issues and the cards are now available for purchase.
Posted Sep 05, 2025 - 05:37 AEST

Investigating

We are experiencing some technical issues with the following eGift cards:

DISNEY_USD
VISA_REWARD_12_MONTH_V_1_USD
CVS_PHARMACY
DOORDASH
BURGER_KING_B2B
EBAY
INSTACART
MICROSOFT_365_FAMILY
NINTENDO_ESHOP
SUBWAY_R_USD

We are working to fix this.
Please check back soon!

MAR-1681
Posted Sep 05, 2025 - 05:08 AEST
This incident affected: Stock Availability (US).