No Lowes $200 stock currently available in AU
Incident Report for Prezzee
Resolved
We have successfully restocked Lowes AU, $200 and these cards are now available for purchase.
Posted Sep 06, 2024 - 13:47 AEST
Identified
We’re experiencing a stock issue with Lowes AU, $200. We’re working hard to get more stock ASAP.
Please check back soon.

ref: MAR-915
Posted May 15, 2024 - 15:47 AEST