Baby Village AU $50 now back in stock
Incident Report for Prezzee
Resolved
We have successfully restocked Baby Village AU $50 and these cards are now available for purchase.
Posted Sep 10, 2024 - 11:38 AEST
Identified
We’re experiencing a stock issue with Baby Village AU $50. We’re working hard to get more stock ASAP.
Please check back soon.

ref: MAR-1117
Posted Sep 05, 2024 - 09:27 AEST
This incident affected: Stock Availability (AU).