We're back online with Lego in AU
Incident Report for Prezzee
Resolved
We have resolved our technical issues and these cards are now available for purchase.

ref: MAR-11121
Posted Sep 10, 2024 - 00:39 AEST
Investigating
We’re having some technical issues at the moment with Lego AU eGift cards and working to fix this. Please check back soon!

ref: MAR-1121
Posted Sep 09, 2024 - 14:33 AEST
This incident affected: Stock Availability (AU).