We're back online with the AU eGift cards

Incident Report for Prezzee

Resolved

We have resolved our technical issues and the cards are now available for purchase.
Posted Mar 03, 2026 - 01:40 AEDT

Update

We’re experiencing some technical issues with the following eGift cards:

* eBay
* Razer Gold
* Kogan

We're working to fix this.
Please check back soon!

MAR-2006
Posted Mar 02, 2026 - 23:36 AEDT

Investigating

We’re experiencing some technical issues with the following eGift cards:

* eBay
* Razer Gold

We're working to fix this.
Please check back soon!

MAR-2006
Posted Mar 02, 2026 - 23:34 AEDT

Identified

We are currently having some technical issues with eBay eGift cards in AU. Updates will be posted here once we know more. We apologise for any inconvenience this may cause.

Please check back soon.

MAR-2006
Posted Mar 02, 2026 - 22:45 AEDT
This incident affected: Stock Availability (AU).