AU eGift cards are back online

Incident Report for Prezzee

Resolved

We have resolved our technical issues and the cards are now available for purchase.

ref: MAR-1757
Posted Oct 20, 2025 - 23:11 AEDT

Investigating

We’re experiencing some {intermittent} technical issues with the following eGift cards:

SHELL_AUD
FLIGHT_CENTRE

We're working to fix this.
Please check back soon!

Ref: MAR-1757
Posted Oct 20, 2025 - 19:46 AEDT
This incident affected: Stock Availability (AU).