We're back online with the AU eGift cards

Incident Report for Prezzee

Resolved

We have resolved our technical issues and the cards are now available for purchase.
Posted Dec 04, 2025 - 18:33 AEDT

Investigating

We are experiencing some technical issues with the following eGift cards:



Coles

AmpolCash

Kmart

Bunnings Warehouse

]Coles Groceries

AmpolCash FUEL ONLY

Target

SHEIN

IKEA

Bill Fairies

Sephora

Officeworks

DiDi Rideshare

Elite Supplements

Gazman

General Pants Co.

Brisbane Restaurants

endota

We are working to fix this.
Please check back soon!

MAR-1875
Posted Dec 04, 2025 - 17:57 AEDT
This incident affected: Stock Availability (AU).