No Princess Highway $100 stock currently available in AU
Incident Report for Prezzee
Resolved
We have just been informed that the technical issues with this brand are because the cards are no longer available for sale and Princess Highway has been discontinued.

We have removed the brand from sale.
Posted Sep 05, 2024 - 14:57 AEST
Identified
We’re experiencing a stock issue with Princess Highway AU $100. We’re working hard to get more stock ASAP.
Please check back soon.

ref: MAR-748
Posted Feb 04, 2024 - 18:57 AEDT