We are experiencing technical issues with Sporting Life in CA

Incident Report for Prezzee

Update

We are currently having some technical issues with Sporting Life eGift cards in CA. Updates will be posted here once we know more. We apologise for any inconvenience this may cause.

Please check back soon.

MAR-2162
Posted May 13, 2026 - 07:41 AEST

Update

We are currently having some technical issues with Sporting Life $150, and $250 eGift cards.

Please check back soon.

MAR-2162
Posted May 13, 2026 - 05:04 AEST

Identified

We are currently having some technical issues with Sporting Life $150 eGift cards in CA. Updates will be posted here once we know more. We apologise for any inconvenience this may cause.

Please check back soon.

MAR-2162
Posted May 12, 2026 - 10:36 AEST
This incident affects: Stock Availability (CA).