We're back online with Petro-Canada in CA
Incident Report for Prezzee
Resolved
We have resolved our technical issues and these cards are now available for purchase.

ref: MAR-1126
Posted Sep 17, 2024 - 14:49 AEST
Investigating
We’re having some technical issues at the moment with Petro-Canada eGift cards and working to fix this. Please check back soon!

ref: MAR-1126
Posted Sep 13, 2024 - 13:01 AEST
This incident affected: Stock Availability (CA).