No Lowes $300 stock currently available in AU
Incident Report for Prezzee
Resolved
We have successfully restocked Lowes AU $300 and these cards are now available for purchase.
Posted Sep 05, 2024 - 12:58 AEST
Identified
We’re experiencing a stock issue with Lowes AU $300. We’re working hard to get more stock ASAP.
Please check back soon.

ref: MAR-738
Posted Jan 28, 2024 - 13:04 AEDT