We are back online with Apple UK £2, £10, £15, £20, £50, £100, and £500 in UK

Incident Report for Prezzee

Resolved

We have resolved our technical issues with Apple UK £2, £10, £15, £20, £50, £100, and £500 in UK. The cards are now available for purchase.
Posted Mar 02, 2026 - 15:44 AEDT

Update

We are currently having some technical issues with Apple UK £2, £10, £15, £20, £50, £100, and £500 eGift cards.

Please check back soon.

MAR-2000
Posted Mar 02, 2026 - 03:00 AEDT

Update

We are currently having some technical issues with Apple UK £10, £50, £500 eGift cards.

Please check back soon.

MAR-2000
Posted Mar 01, 2026 - 16:18 AEDT

Update

We are currently having some technical issues with Apple UK £10, £500 eGift cards.

Please check back soon.

MAR-2000
Posted Mar 01, 2026 - 15:59 AEDT

Identified

We are currently having some technical issues with Apple UK £500 eGift cards in UK. Updates will be posted here once we know more. We apologise for any inconvenience this may cause.

Please check back soon.

MAR-2000
Posted Mar 01, 2026 - 15:19 AEDT
This incident affected: Stock Availability (UK).