We are back online with Hotels.com in AU

Incident Report for Prezzee

Resolved

We have resolved our technical issues with Hotels.com in AU. The cards are now available for purchase.
Posted Sep 11, 2025 - 22:05 AEST

Identified

We are currently having some technical issues with Hotels.com eGift cards in AU. Updates will be posted here once we know more. We apologise for any inconvenience this may cause.

Please check back soon.

MAR-1699
Posted Sep 11, 2025 - 18:20 AEST
This incident affected: Stock Availability (AU).