No Smoothie King $5, $10 $15 and $75 stock currently available in US
Incident Report for Prezzee
Update
We are continuing to work on a fix for this issue.
Posted Jul 05, 2024 - 09:16 AEST
Update
We’re experiencing a stock issue with Smoothie King US $10 and $15 . We’re working hard to get more stock ASAP.
Please check back soon.

ref: MAR-974
Posted Jun 22, 2024 - 08:50 AEST
Identified
We’re experiencing a stock issue with Smoothie King US $15 . We’re working hard to get more stock ASAP.
Please check back soon.

ref: MAR-974
Posted Jun 15, 2024 - 08:49 AEST