We are back online with Ultimate Game Pass - 1 Months Subscription £12.99 in UK

Incident Report for Prezzee

Resolved

We have resolved our technical issues with Ultimate Game Pass - 1 Months Subscription £12.99 in UK. The cards are now available for purchase.
Posted Sep 08, 2025 - 01:11 AEST

Identified

We are currently having some technical issues with Ultimate Game Pass - 1 Months Subscription £12.99 eGift cards in UK. Updates will be posted here once we know more. We apologise for any inconvenience this may cause.

Please check back soon.

MAR-1675
Posted Sep 03, 2025 - 02:18 AEST
This incident affected: Stock Availability (UK).