We're experiencing technical issues with Laithwaite's £100 in UK

Incident Report for Prezzee

Update

We are continuing to investigate this issue.
Posted Oct 18, 2024 - 02:18 AEDT

Investigating

We’re having some technical issues at the moment with Laithwaite's £100 eGift cards and working to fix this. Please check back soon!

ref: MAR-1199
Posted Oct 18, 2024 - 02:16 AEDT
This incident affects: Stock Availability (UK).